Close

Is My Device Supported?

Apple / iOS

VSCO is compatible on iPhone 6S and newer running iOS 11 and above. For more information on what devices and iOS versions Apple supports, please see the following article. 

 

Android

VSCO is compatible on most Android devices running Android 5.0 and above. For more information about devices and which ones are supported on Android 5.0 and above, please see the following article. 

Please note that even if an Android device can run Android 5.0, this device still may not be supported by VSCO. Unfortunately, VSCO is unable to provide a list of unsupported Android devices due to how many device models are available. 

 

For optimum performance of the VSCO app, we recommend having minimum of 500MB of storage capacity when installing and using the app.

VSCO does not support rooted or jailbroken devices.